svchostがCPUを100%使ってしまうトラブル発生!!解決までの長い道のり・・・

a0001_009296 ハードディスクの壊れたお客様からパソコンを預かりハードディスクの交換とOSの再インストール。 ここまでは良くある話なんですが、今回はちょっとそんな単純な話ではありませんでした。

預かったパソコンをチェックしてみる

今回の預かったパソコンは富士通の【CE50L7】と言う型番。正式には【FMVCE50L7】と言う品名の機種です。 発売日が2005年4月ともう10年も前のパソコンになります。 インストールされているOSはもちろんWindowsXPです。 来年2014年4月にWindowsXPのサポート切れるので、こういう場合だいたい買い替えをオススメし、実際に買い替えられる方がほとんどなんですが、今回のお客様はできれば修理したいと言うことで修理することになりました。 とりあえず現状把握のためにパソコンを起動すると、画面には「Operating System not found」と表示され、ハードディスクのカタンカタンと言う音がループする状態。 BIOSをチェックしましたがハードディスク自体を認識してないようです。 これは完全にハードディスクの故障ですね・・・ お客様に現状を説明し中身について聞きましたが、別に大切なデータは入ってないので復旧する必要はないとのこと。 これはハードディスクを交換しOSを再インストールすればすぐに直ると思っていたのですが・・・ まさかこんな罠が待っていようとは・・・

怪しい動きの【svchost.exe】・・・

ハードディスクを交換し、リカバリCDから起動してみるとちゃんとリカバリを始めました。 このくらいに発売された富士通のパソコンの場合、ちゃんとリカバリCDとアプリケーションCDがついているので安心です。 OSの再インストールが無事終了し、アプリケーション類を入れているときにふとあることに気がつきました。 ・・・あまりにインストールが遅い・・・ まあ10年前の機種なのでこのくらいかとも思いましたが、あまりに遅いのでタスクマネージャを開いてみるとCPUの使用率が100%になっているじゃあないですか。 それもインストールファイルとまったく関係なさそうな【svchost.exe】と言うファイルが・・・ svchost_error アプリケーション類は必要なモノだけを入れていたのでインストールが終わってからみても、同じように【svchost.exe】がほぼ100%の状態です。 通常、svchost.exeがいくつかあるのはまあ普通なんですが、怪しいソフトがsvchost.exeを使うこともあるんです。 でも今回はリカバリをしたばっかりなので怪しいソフトが動いている可能性はほぼあるわけないはずです。 プロセスの終了をすれば動作は軽くなるんですが、タスクバーあたりの表示がおかしな感じになります。 これはどこかがおかしい・・・ 検索してみると、出てくる出てく!!それも日付が2013年10月など最近のものばかり!!
https://www.google.co.jp/search?q=windows+%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB+svchost.exe+100%25#q=svchost.exe+100%25&safe=off
svchost.exe 100% – Google 検索
検索して出てきたサイトをいくつか見ていてある結論に達しました。 Windows Updateがおかしい!!

原因はWindows Updateにあった!!

検索ででてきたサイトの中に日本マイクロソフトのブログがあったので見ましたが・・・何が言いたいのかよくわからない(^^; とにかく症状は確認しているが、直ったものもあれば直ってないものもあることがわかった。 原因がアップデートにあるならLANケーブルを抜けばいいと思ったけど、svchostは変わらずに100%のまま。 アップデートが通信をしているから100%になっているわけではないみたい。 じゃあアップデートのサービスを停止させようって事で【コントロールパネル】→【管理ツール】の【Automatic Updates】を【自動】から【無効】にしてやって再起動。 これでとりあえずsvchostが100%になるのは治まりました。 <参考サイト> でもこのままじゃアップデートをONにも出来ないし、セキュリティ的にも危険ないのでアップデートはしてやらないと行けません。 結局↓のサイトを参考に原因のアップデートを手動で適用してやって、その後他のアップデートを実行することにも成功しました。

今回のまとめ

update Windowsのアップデートが起こしたトラブルは今までも何度かありましたが、10月に症状が発覚し2ヶ月たった今も公式に解決方法がマイクロソフトから発表されていないのもどうなのかな~と思いますね。 今までのアップデートをしていればこの症状は起きないのかもしれませんが、おそらくこの症状で悩んでいる方はたくさんいるのではないでしょうか? もしかしたら「最近パソコンが重くなった~」で済ましている人もたくさんいるのではないかと思います。 それにしてもWindowsXPのサポートが切れるギリギリにこんな事が起こるとは・・・ 疑いたくはありませんが、偶然起きたようには思えない出来事でした。

コメントを残す

メールアドレスが公開されることはありません。